UCaaS: Intermittent Cytracom Desktop Outage

Incident Report for Cytracom

Resolved

This issue has been resolved. Affected users must hard refresh the Desktop web page (hold shift, click refresh) before logging in.
Posted Oct 22, 2025 - 11:11 CDT

Monitoring

We have deployed a fix for the Cytracom Desktop Authentication issue.
Posted Oct 22, 2025 - 10:49 CDT

Investigating

We have identified an issue that prevents some users from authenticating into Cytracom Desktop App. We are working on a fix and it will be applied shortly.
Posted Oct 22, 2025 - 10:12 CDT
This incident affected: Client Applications (Desktop).