Some users unable to make & receive calls in the Desktop app
Incident Report for Cytracom
Resolved
After making infrastructure changes and updating the backend service responsible for call completion in the Desktop App, we have observed no further occurrences of the issue and this incident is being marked as resolved.
Posted Aug 02, 2021 - 15:07 CDT
Update
We have implemented additional changes to resolve this issue and are currently monitoring to validate service restoration.
Posted Jul 27, 2021 - 19:42 CDT
Update
We have seen an occasional recurrence of the issue with the aforementioned backend service. Although we have mitigants in place to reduce impact, we have seen that Desktop app users are still experiencing intermittent issues with being able to make and receive calls, and some calls dropping, when the service becomes unavailable for very brief periods of time. This issue is still limited to the Desktop app exclusively. We are actively investigating and monitoring. Additional updates will be provided as they become available.
Posted Jul 27, 2021 - 14:53 CDT
Monitoring
We identified an issue related to a backend service responsible for certain voice-related connections in the Desktop application. We have implemented changes to mitigate this issue and are currently monitoring to validate service restoration. Some users that were impacted may find it necessary to refresh — Ctrl + F5 (PC) or ⌘ Command + R (Mac) — or restart their Cytracom Desktop app in order to re-establish connectivity.
Posted Jul 27, 2021 - 11:51 CDT
Investigating
We are currently investigating an issue, within the Cytracom Desktop app specifically, intermittently preventing users from making or receiving calls within the app. There is no impact to the Cytracom Business Phone System (e.g. D2 desk phones) or Mobile apps (iOS and Android). We will continue to post updates here as soon as they become available.
Posted Jul 27, 2021 - 09:51 CDT
This incident affected: Client Applications (Desktop).