A fix has been deployed for Cytracom Desktop users, and engineers are actively monitoring application performance. Users should refresh their session to ensure the latest version of Cytracom Desktop is installed.
If you have any questions or need assistance, our team is available at support@cytracom.com or 877-411-2987.
Posted May 13, 2025 - 12:42 CDT
Identified
The source of crashes associated with Cytracom Desktop has been identified and engineers are working on a fix. The user experience at this time has returned to normal, however, once the fix is implemented the status will be updated.
Posted May 13, 2025 - 10:14 CDT
Investigating
Engineers are investigating reports of call failures and application crashes when using the Cytracom Desktop application to place and receive calls.
Posted May 13, 2025 - 08:33 CDT
This incident affected: Voice Services (Call Completion, Call Center).