Voice Services Degradation
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 12:05 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2024 - 11:51 CDT
Identified
We have identified an issue affecting call completion for a subset of our customers. Cytracom Engineering is working to resolve this and will provide updates here.
Posted Apr 11, 2024 - 11:15 CDT
This incident affected: Voice Services (Call Completion, Voicemail, Call Center).